SKlauncher 3.0 New

A completely new, rewritten launcher with new features such as themes, support for premium accounts, skins, capes and many more!

Launcher no longer requires Java 8, now you can run SKlauncher with Java 8, or with Java 11+

For Windows Users

Launcher currently requires Java 11-18 to work properly, so we recommend to use Adoptium OpenJDK.
Alternatively Java 8 with JavaFX, so you can use Liberica Full JRE 8.
If you prefer Liberica, make sure to choose Full JRE, not Standard JRE.

For Linux Users

Launcher currently requires Java 11-18 to work properly, so you should have it installed already.
However, if you experience issues, you can try Adoptium OpenJDK.

For macOS Users

Launcher currently requires Java 11-18 to work properly, so you should have it installed already.
However, if you experience issues, you can try Adoptium OpenJDK.